1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Herzlich Willkommen auf der Internet-Plattform zum Edelmänner-Server!
    Du bist aktuell Gast auf unserer Website und hast nur eingeschränkten Zugriff auf manche Foren.
    Um vollständigen Zugriff auf unser Forum zu erhalten, musst du dich zuerst mit deinem Minecraft-Namen in unserem Forum registrieren und dich zu einem Spieler bewerben. Mit dieser Bewerbung einhergehend ist auch die Einstufung als Spieler auf unserem Minecraft-Server.

    Server-Adresse: s.edelmaenner.net
    Version: 1.13.2

    Schau doch mal vorbei!
    Information ausblenden

Mod ähnlich Shematica/Litematica

Dieses Thema im Forum "Allgemeine Diskussionen" wurde erstellt von gonzocryper, 22. Juni 2019.

  1. gonzocryper

    Spieler

    Registriert seit:
    25. Sep. 2014
    Beiträge:
    27
    Zustimmungen:
    0
    Hallo,

    hat einer von euch einen Mod so wie oben genannt oder ähnlich am laufen? Trotz diverser Tutorials bekomme ich es für die 1.13.2 nicht hin.

    Gruß
     
  2. Zweistein2

    Zweistein2 Forengestein
    Administrator

    Registriert seit:
    26. Aug. 2014
    Beiträge:
    793
    Zustimmungen:
    359
    Litematica habe ich installiert. Ist von der Bedienung her mega bescheiden, aber solange es kein Schematica für 1.13.2 gibt...

    Zuerst... Riftmod installieren: https://www.curseforge.com/minecraft/mc-mods/rift/files/2610741
    Dann MaLib runterladen und ins mod-Verzeichnis packen: https://www.curseforge.com/minecraft/mc-mods/malilib/files/2652836
    Dann Litematica runterladen und ins mod-Verzeichnis packen: https://www.curseforge.com/minecraft/mc-mods/litematica/files/2723388

    Dass sollte es dann auch gewesen sein. (Hab mal meine Versionen genommen und nicht die aktuellsten)

    Wie man es dann bedient: https://pastebin.com/qVWXiy9h
     
    #2 Zweistein2, 22. Juni 2019
    Zuletzt bearbeitet: 28. Juni 2019
    • Informativ Informativ x 1
  3. gonzocryper

    Spieler

    Registriert seit:
    25. Sep. 2014
    Beiträge:
    27
    Zustimmungen:
    0
    Das ist genau der Weg den ich mit verschiedensten Versionen probiert habe. Rift installieren scheint zu funktionieren zumindest startet es normal. Aber sobald ich die anderen Dateien in den MODs Ordener packe. Kommt die Spielabstutz Meldung. Ich vermute mal das es ein Problem mit Java gibt, ich habe ein Linux als OS.

    Aber danke für die Mühe.

    Unable to launch java.lang.RuntimeException: java.lang.reflect.InvocationTargetException at org.dimdev.riftloader.launch.RiftLoaderTweaker.injectIntoClassLoader(RiftLoaderTweaker.java:28) at net.minecraft.launchwrapper.Launch.launch(Launch.java:115) at net.minecraft.launchwrapper.Launch.main(Launch.java:28) Caused by: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.dimdev.riftloader.launch.RiftLoaderTweaker.injectIntoClassLoader(RiftLoaderTweaker.java:26) ... 2 more Caused by: java.lang.NoClassDefFoundError: fi/dy/masa/malilib/interfaces/IInitializationHandler at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:348) at org.dimdev.riftloader.RiftLoader.loadListeners(RiftLoader.java:248) at org.dimdev.riftloader.RiftLoader.getListeners(RiftLoader.java:233) at org.dimdev.riftloader.RiftLoader.initMods(RiftLoader.java:188) at org.dimdev.riftloader.RiftLoader.load(RiftLoader.java:54) ... 7 more Caused by: java.lang.ClassNotFoundException: fi.dy.masa.malilib.interfaces.IInitializationHandler at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ... 13 more Caused by: java.lang.NullPointerException at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182) ... 15 more
     
  4. Zweistein2

    Zweistein2 Forengestein
    Administrator

    Registriert seit:
    26. Aug. 2014
    Beiträge:
    793
    Zustimmungen:
    359
    Scheint als hätte er Probleme MaLib zu laden. Welche Version von Rift und MaLib nutzt du?
     
  5. gonzocryper

    Spieler

    Registriert seit:
    25. Sep. 2014
    Beiträge:
    27
    Zustimmungen:
    0
    so wie du es verlinkt hast

    Es gibt vorher noch eine Warnung zu "mixin"

    Couldn't get hash for org/dimdev/mixin/0.7.11-SNAPSHOT/mixin-0.7.11-SNAPSHOT.jar from https://www.dimdev.org/maven/org/dimdev/mixin/0.7.11-SNAPSHOT/mixin-0.7.11-SNAPSHOT.jar.sha1: HTTP 404: Not Found

    Have local file /home/niva-wiki/.minecraft/libraries/org/dimdev/mixin/0.7.11-SNAPSHOT/mixin-0.7.11-SNAPSHOT.jar but don't know what size or hash it should be. Have to assume it's good.

    Die jar ist an der Stelle und auch von Hand da einfügen ändert nicht.

    Ich hantiere hier mit Java 8 rum.
     
  6. Zweistein2

    Zweistein2 Forengestein
    Administrator

    Registriert seit:
    26. Aug. 2014
    Beiträge:
    793
    Zustimmungen:
    359
    Hmm, das Sollte eigentlich kein Problem darstellen.

    Sonst noch irgendwelche Mods im Mods-Ordner?
     
  7. gonzocryper

    Spieler

    Registriert seit:
    25. Sep. 2014
    Beiträge:
    27
    Zustimmungen:
    0
    Nein, keine anderen Mods, Hab MC komplett neu aufgespielt.
    Vielleicht probier ich mal einen andern Mod unter Rift um zu sehen ob die Rift 1.13 überhaupt mit Mod geht.

    Gruß
     
  8. __kreck

    Spieler

    Registriert seit:
    30. Apr. 2017
    Beiträge:
    43
    Zustimmungen:
    4
    Hi,

    ich habe es mal getestet. Wenn du die richtigen Files und Java-Version hast sollte es klappen.

    verfügbare installierte Java Versionen:
    Code:
    user@t400 ~ % archlinux-java status
    Available Java environments:
      java-10-openjdk
      java-11-openjdk
      java-8-openjdk/jre (default)
    
    installierte Minecraft Versionen:
    Code:
    user@t400 ~ % ls ~/.minecraft/versions
    1.13.2  1.13.2-rift-1.0.4-SNAPSHOT
    
    installierte Mods:
    Code:
    user@t400 ~ % ls -l ~/.minecraft/mods
    total 3752
    -rw-r--r-- 1 user users 2709891 Apr  6 06:33 OptiFine_1.13.2_HD_U_E7.jar
    -rw-r--r-- 1 user users  736973 Jun 27 20:29 litematica-rift-1.13.2-0.0.0-dev.20190611.200317.jar
    -rw-r--r-- 1 user users  392900 Jun 27 20:31 malilib-rift-1.13.2-0.10.0-dev.19.jar
    
    wichtig das du die .jar lädst inkl. der passenden Version 1.13.2 und nicht die .litemod oder 1.14.x !

    MaLiLib JAR: https://www.curseforge.com/minecraft/mc-mods/malilib/download/2723360
    Litematica JAR:https://www.curseforge.com/minecraft/mc-mods/litematica/download/2723388


    Gruß und viel erfolg,
    __kreck
     
  9. gonzocryper

    Spieler

    Registriert seit:
    25. Sep. 2014
    Beiträge:
    27
    Zustimmungen:
    0
    Vielleicht bekomme ich es mit eurer Hilfe doch noch hin.

    Habe Rift installiert aus dem Link von Zweistein2.
    Dann habe ich im Versionsordner eine 1.13-rift-1.0.4.66

    Das unterscheidet sich schonmal von der Version bei _kreck. Liegt da schon ein Problem?

    Die beider Links von _kreck habe ich runtergeladen und in den MOD-Ordner verschoben. So richtig?

    Was vielleicht noch wichtig ist, die Java-Version ist "OpenJDK Java 8 Runtime"
     
  10. Brogamer5000

    Brogamer5000 Der Techniker ihres Vertrauens
    Stammi

    Registriert seit:
    19. Juni 2015
    Beiträge:
    187
    Zustimmungen:
    107